UFT Object Repository Test Object Icon Issue

  • Questions
  • UFT Object Repository Test Object Icon Issue
Tags:
Question ID: 107602
1
0

A new issue has started where our test object icons appear all as the 3D cube with the green/yellow/red sides showing. Each Test Object Class has always had its respective icon, but now they all appear as those cubes. How do we fix this?

Marked as spam
Posted by (Questions: 359, Answers: 26)
Asked on April 25, 2017 5:53 pm
8 views
Answers (1)
1
Private answer

This is a known corruption issue; please reference KM528123 to verify and fix the paths in the provided registry key (see below). If that doesn't work, might have to resort to a manual clean uninstall/reinstall using KM00319750.

1. Navigate to the registry key of the test object:
HKEY_CURRENT_USERSoftwareMercury InteractiveQuickTest ProfessionalMicTestTest Objects\Icons

2. (Optional/Recommended) Find a machine where the issue is not present.

3. Verify that the full paths of the registry values under this key are correct.

Example: The registry values under the above registry key for a web test object should look like: binWWWPackage.dll,,

Marked as spam
Posted by (Questions: 0, Answers: 707)
Answered on April 25, 2017 5:53 pm
I have confirmed that the registry file paths are different between a machine where the icons are correct vs. a machine where they are incorrect. Correct: C:\Program Files (x86)\HP\Unified Functional Testing\\bin\WWWPackage.dll,213,213 Incorrect: C:\Program Files (x86)\HP\Unified Functional Testing\\bin\AddinsCoreResources.dll,14213,14213 I then followed the ''Delete Any Traces Left'' section of the manual cleanup instructions, and it worked! Thanks!
( at April 25, 2017 5:54 pm)