Unable to Bind LDAP error in ALM?

Question ID: 105116
0
0

Hello,
We are experiencing an error when trying to sett up the LDAP within SIte Admin. The LDAP connection tests fine (we are using anonymous selection for authentication) and then we complete the setup and the LDAP fails to work for the keyword search. It returns the following error statement:

Failed to Login;
netscape.ldap.LDAPException: error result (1); 000004DC: LdapErr: DSID-0C0906E8, comment: In order to perform this operation a successful bind must be completed on the connection., data 0, v1db1 ;

What could be the issue and are there any workarounds?

Marked as spam
Posted by (Questions: 328, Answers: 20)
Asked on September 6, 2013 2:06 pm
11 views
Answers (2)
1
Private answer

Hi HomerJ,

Have you tried changing to simple authentication and entring in the admin credentials (or your credentials if you have the correct permissions) to test that the system is connecting. It appears as though the system is not authenticating to the LDAP server (creating a binding) to allow the import of the user data. Generally you will use the default configurations and not have to change anything (you may have to add the domain to the front of the username or maye have to format it as an email, ie add the @company.com information). When this information is entered correctly you should be able to test and verify the connection correctly. I would suggest that you try the simple authentication settings to see if that solves your issue. It also could be that you are using SSL and don't have it correctly configured with the Site Admin statements regarding SSL authentication added (these can be found within the administrator's guide for ALM 11).

I Hope these suggestions help,
Dan

Marked as spam
Posted by (Questions: 0, Answers: 722)
Answered on September 6, 2013 2:12 pm
Thanks for the suggestions. We tried the simple authentication and was able to bind. We then set up a master account to use for LDAP importation (one that has the permission levels that allow all the domain trees to be seen for adding users. We tested and are now able to import users without issue. Thanks for the help.
( at September 6, 2013 2:14 pm)
0
Private answer

Hi master:
'We then set up a master account to use for LDAP importation ', how to set up a master account, I meet the same issue.
thanks
andy

Marked as spam
Posted by (Questions: 0, Answers: 2)
Answered on June 4, 2014 1:33 pm
The master account would need to be set up with the same permissions as the other accounts, but it would need to be at a root type of level, one that is parent to all other groups (hence the ''root'' level grouping suggestion) so that this account can then see all other users to be able to add them to ALM/QC. You will probably want to make the password for this account non-expiring as well so issues in the future can be avoided.
( at June 9, 2014 1:51 pm)