Unable to run Site Admin from Citrix Server

Question ID: 109526
0
0

We are unable to run the Site Admin from the Citrix XenApp 6.5, Server 2008 R2. Error attached

Attachments:
Marked as spam
Posted by (Questions: 97, Answers: 6)
Asked on April 30, 2020 1:50 pm
6 views
Answers
0
Private answer

The problem is probably that you installed the ALM client on the Citrix server/workstation using the Client MSI Generator which creates an executable file that you can use to install the ALM client. When the client is created using the MSI Generator it will not automatically update when ALM is upgraded as it would if it were installed by going to the ALM site and downloading the client automatically.

To check to see if this is the issue you will need to go to Add/Remove programs on the Citrix server and see if the ALM client is showing up in add/remove programs (also the version will probably be 12.53.x). If the ALM client is present in add/remove programs then the client was installed using the executable MSI file.

If this is the case you will need to remove the ALM client from Add/Remove programs then either browse to the site to have the client (or site admin) installed automatically or you will need to create a new MSI and install it using the MSI generator for ALM version 12.6x that I am attaching to the case along with the user guide that explains how to us the MSI generator. Please read through user guide before trying to create the MSI.

Since this is a Citrix server you will want to check the option for "Shared Deployment Mode" when creating the MSI file.

Once you have created the file you will need to log into the Citrix server as a local admin to install the MSI file. After that additional users will not need to login as a local admin to run the client this is just for the installation.

Description

The ALM Client MSI Generator Add-in enables you to generate MSI files for locally deploying ALM client components on workstations.

Installation Instructions and Prerequisites

Prerequisite: Microsoft .NET Framework 4.0 or 4.5 must be installed on the machine on which you want to run ALM Client MSI Generator

Uninstall any other versions of this add-in

Refer to the ALM Client MSI Generator User Guide to review additional important installation instructions

Install this add-in on your ALM client machine

Note: To install this add-in you must log in with administrator privilege

Marked as spam
Posted by (Questions: 0, Answers: 288)
Answered on April 30, 2020 1:51 pm