VuGen telling me to install WSE 2 and WSE 3 when I try the create Web Services script, Do I really need to install them?

Question ID: 109172
1
0

I just took an existing Web Services script that is rock solid, been running weekly with no issues for 18+ months. This script was created in LR 12.50

I just coped it and tried to run it in the VuGen version 12.55, and/or 12.63.

I see this error immediately. Never saw this message before and never had to install anything additional before.
ERROR from VuGen replay logs:

Action.c(49): Error: To continue, WSE2 and WSE3 must be installed on your machine. The setup programs for WSE2.0 SP3 and WSE3.0 are included in the [LoadRunner installation]\\lrunner\\Common folder or can be downloaded from the Internet. [Time:2019-08-05 07:54:37]

Action.c(66): Error: To continue, WSE2 and WSE3 must be installed on your machine. The setup programs for WSE2.0 SP3 and WSE3.0 are included in the [LoadRunner installation]\\lrunner\\Common folder or can be downloaded from the Internet. [Time:2019-08-05 07:54:37]

Marked as spam
Posted by (Questions: 227, Answers: 18)
Asked on August 28, 2019 6:11 pm
1098 views
Answers (2)
1
Private answer

YES, if you want to create and run Web Services scripts in version 12.55 and higher, you must install the following prerequisite software for all LoadRunner (full setup), Standalone VuGen machines and ALL Standalone LGs machines:

**- .NET Framework 3.5 (required for WSE 2 & 3)

- WSE2 is Web Services Enhancements (WSE) 2.0 SP3 for Microsoft .NET Redistributable Runtime MSI

- WSE3 is Web Services Enhancements (WSE) 3.0 for Microsoft .NET Redistributable Runtime MSI**

If you are installing on a Windows 8.1/10 or Windows 2012 (R2)/ 2016 machine, the .NET 3.5 must be turned on, and WSE 2.0 SP3 and WSE 3.0 must be installed.

1. Turn on **.NET 3.5** Windows. (See MSDN for details. https://docs.microsoft.com/en-us/dotnet/framework/install/dotnet-35-windows-10 )
2. Install the WSE components from the LoadRunner installation package's folders-

a. ...lrunnerCommonwse20sp3

b. ...lrunnerCommonwse30

c. or download these components from Microsoft directly

NOTE LoadRunner does not automatic install these prerequisites.

Marked as spam
Posted by (Questions: 12, Answers: 379)
Answered on August 28, 2019 6:46 pm
0
Private answer

UPDATE

According to Micro Focus 3.5 NET is still needed:

FROM the VuGen 2021 help site:

  • Depending on your toolkit and API usage, you may get an error if you need to install/activate one or more of WSE 2.0 SP3, WSE 3.0, and .NET 3.5. This is required if, when using the Axis or .NET toolkits, your script contains one of the following API functions:
    • web_service_set_security
    • web_service_set_security_saml
    • web_service_call

    Solutions:

    • Activate .NET 3.5. Turn on the feature as described in the MSDN.

      Next, install the WSE components from your LoadRunner Professional installation package folders, lrunnerCommonwse20sp3 and lrunnerCommonwse30, or download them from the Internet.

    • Alternatively, move to the WCF toolkit instead. With WCF toolkit, you can use web_service_set_security without installing WSE2.0 or WSE3.0.

      We also highly recommend that you use web_service_set_security_saml_ex instead of web_service_set_security_saml (in the WCF toolkit).

 

 

Marked as spam
Posted by (Questions: 12, Answers: 379)
Answered on April 27, 2021 2:56 pm
EyeOnTesting